PHP4 ist für Joomla! nun nicht mehr „up to date“

php5Mit der Joomla! Version 1.5.15 sind die Mindestanforderungen an die Serverumgebung gestiegen. Die Version ist nun nur noch mit PHP5 optimal lauffähig und Fehler aus der Version 1.5.14 – Joomla Fehlermeldungen bei PHP Version 5.3 – wurden behoben.

Es gibt eine Notlösung für PHP4 Nutzer, so sie denn keine Möglichkeit der Änderung nach PHP5 haben.

Im Ordner “ libraries/joomla/application/pathway.php “ ändern Sie die letzte Funktion zu:

 

function _makeItem($name, $link)
{
$item = new stdClass();
if((version_compare( phpversion(), ‚5.0‘ ) < 0)) {
$item->name = html_entity_decode($name);
} else {
$item->name = html_entity_decode($name, ENT_COMPAT, ‚UTF-8‘);
}
$item->link = $link;

return $item;
}

Quelle

Read Full Article

php5Mit der Joomla! Version 1.5.15 sind die Mindestanforderungen an die Serverumgebung gestiegen. Die Version ist nun nur noch mit PHP5 optimal lauffähig und Fehler aus der Version 1.5.14 – Joomla Fehlermeldungen bei PHP Version 5.3 – wurden behoben.

Es gibt eine Notlösung für PHP4 Nutzer, so sie denn keine Möglichkeit der Änderung nach PHP5 haben.

Im Ordner “ libraries/joomla/application/pathway.php “ ändern Sie die letzte Funktion zu:

 

function _makeItem($name, $link)
{
$item = new stdClass();
if((version_compare( phpversion(), ‚5.0‘ ) < 0)) {
$item->name = html_entity_decode($name);
} else {
$item->name = html_entity_decode($name, ENT_COMPAT, ‚UTF-8‘);
}
$item->link = $link;

return $item;
}

Quelle

Kommentar verfassen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.